What’s Vulnerable › Vulnerabilities
CVE-2025-69195: Wget2: gnu wget2: memory corruption and crash via filename sanitization logic with attacker-controlled urls
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-09 · updated 2026-06-17
- Weakness: CWE-121
Description
A flaw was found in GNU Wget2. This vulnerability, a stack-based buffer overflow, occurs in the filename sanitization logic when processing attacker-controlled URL paths, particularly when filename restriction options are active. A remote attacker can exploit this by providing a specially crafted URL, which, upon user interaction with wget2, can lead to memory corruption. This can cause the application to crash and potentially allow for further malicious activities.
Affected products
- gnu wget2: from 2.1.0 before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: gnu wget2 2.2.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-69195
- https://bugzilla.redhat.com/show_bug.cgi?id=2425770
Get alerted when CVE-2025-69195 or the next vulnerability affects your stack