What’s Vulnerable › Vulnerabilities
CVE-2025-69200: phpMyFAQ has unauthenticated config backup download via /api/setup/backup
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-29 · updated 2026-10-07
- Weakness: CWE-202
Description
phpMyFAQ is an open source FAQ web application. In versions prior to 4.0.16, an unauthenticated remote attacker can trigger generation of a configuration backup ZIP via `POST /api/setup/backup` and then download the generated ZIP from a web-accessible location. The ZIP contains sensitive configuration files (e.g., `database.php` with database credentials), leading to high-impact information disclosure and potential follow-on compromise. Version 4.0.16 fixes the issue.
Affected products
- thorsten phpMyFAQ: before 4.0.16; 4.1.0-rc — fixed in 4.0.16
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.0.16. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/commit/b0e99ee3695152115841cb546d8dce64ceb8c29a
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9cg9-4h4f-j6fg
Get alerted when CVE-2025-69200 or the next vulnerability affects your stack