What’s Vulnerable › Vulnerabilities
CVE-2025-69201: Tugtainer has RCE in Agent Command Execution Api
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-29 · updated 2026-10-07
- Weakness: CWE-77
Description
Tugtainer is a self-hosted app for automating updates of docker containers. In versions prior to 1.15.1, arbitary arguments can be injected in tugtainer-agent `POST api/command/run`. Version 1.15.1 fixes the issue.
Affected products
- Quenary tugtainer: before 1.15.1 — fixed in 1.15.1
How to fix
Upgrade to a fixed version: Quenary tugtainer 1.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/Quenary/tugtainer/commit/dbb17d843e30fd7509acf0328c913dcb42f40831
- https://github.com/Quenary/tugtainer/pull/88
- https://github.com/Quenary/tugtainer/releases/tag/v1.15.1
- https://github.com/Quenary/tugtainer/security/advisories/GHSA-grc3-8w5x-g54q
Get alerted when CVE-2025-69201 or the next vulnerability affects your stack