What’s Vulnerable › Vulnerabilities
CVE-2025-69204: ImageMagick converting a malicious MVG file to SVG caused an integer overflow.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-30 · updated 2026-06-17
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-12, in the WriteSVGImage function, using an int variable to store number_attributes caused an integer overflow. This, in turn, triggered a buffer overflow and caused a DoS attack. Version 7.1.2-12 fixes the issue.
Affected products
- ImageMagick: before 7.1.2-12 — fixed in 7.1.2-12
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-12. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/2c08c2311693759153c9aa99a6b2dcb5f985681e
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-hrh7-j8q2-4qcw
Get alerted when CVE-2025-69204 or the next vulnerability affects your stack