What’s Vulnerable › Vulnerabilities
CVE-2025-69231: OpenEMR has a Stored XSS in GAD-7 Form that Enables Session Hijacking and Privilege Escalation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 8.0.0, a stored cross-site scripting vulnerability in the GAD-7 anxiety assessment form allows authenticated users with clinician privileges to inject malicious JavaScript that executes when other users view the form. This enables session hijacking, account takeover, and privilege escalation from clinician to administrator. Version 8.0.0 fixes the issue.
Affected products
- openemr: before 8.0.0 — fixed in 8.0.0
How to fix
Upgrade to a fixed version: openemr 8.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/5f20b756441fc9868f43410a9ef97536c38b2ba6
- https://github.com/openemr/openemr/security/advisories/GHSA-mf62-q2xc-hxm3
Get alerted when CVE-2025-69231 or the next vulnerability affects your stack