What’s Vulnerable › Vulnerabilities
CVE-2025-69233: Apache CloudStack: Domain/account resources limits not honored
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-07
- Weakness: CWE-367
Description
Due to multiple time-of-check time-of-use race conditions in the resource count check and increment logic, as well as missing validations, users of the platform are able to exceed the allocation limits configured for their accounts/domains. This can be used by an attacker to degrade the infrastructure's resources and lead to denial of service conditions. Users are recommended to upgrade to Apache CloudStack versions 4.20.3.0 or 4.22.0.1, or later, which fixes this issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.0.0 before 4.20.3.0; from 4.21.0.0 before 4.22.0.1 — fixed in 4.20.3.0, 4.22.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.20.3.0, 4.22.0.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm
- http://www.openwall.com/lists/oss-security/2026/05/09/5
Get alerted when CVE-2025-69233 or the next vulnerability affects your stack