What’s Vulnerable › Vulnerabilities
CVE-2025-69263: pnpm Lockfile Integrity Bypass Allows Remote Dynamic Dependencies
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-07 · updated 2026-10-14
- Weakness: CWE-494
Description
pnpm is a package manager. Versions 10.26.2 and below store HTTP tarball dependencies (and git-hosted tarballs) in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. An attacker who publishes a package with an HTTP tarball dependency can serve different code to different users or CI/CD environments. The attack requires the victim to install a package that has an HTTP/git tarball in its dependency tree. The victim's lockfile provides no protection. This issue is fixed in version 10.26.0.
Affected products
- pnpm: before 10.26.0 — fixed in 10.26.0
How to fix
Upgrade to a fixed version: pnpm 10.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/commit/0958027f88a99ccefe7e9676cdebba393dfbdc85
- https://github.com/pnpm/pnpm/security/advisories/GHSA-7vhp-vf5g-r2fw
- https://access.redhat.com/security/cve/CVE-2025-69263
- https://bugzilla.redhat.com/show_bug.cgi?id=2427703
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-69263.json
Get alerted when CVE-2025-69263 or the next vulnerability affects your stack