What’s Vulnerable › Vulnerabilities
CVE-2025-69264: pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-07 · updated 2026-10-14
- Weakness: CWE-693
Description
pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.
Affected products
- pnpm: from 10.0.0 before 10.26.0 — fixed in 10.26.0
How to fix
Upgrade to a fixed version: pnpm 10.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/pnpm/pnpm/commit/73cc63504d9bc360c43e4b2feb9080677f03c5b5
- https://github.com/pnpm/pnpm/security/advisories/GHSA-379q-355j-w6rj
- https://access.redhat.com/security/cve/CVE-2025-69264
- https://bugzilla.redhat.com/show_bug.cgi?id=2427709
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-69264.json
Get alerted when CVE-2025-69264 or the next vulnerability affects your stack