What’s Vulnerable › Vulnerabilities
CVE-2025-69289: Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-863
Description
Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.
Affected products
- discourse: before 3.5.4; from 2025.11.0 before 2025.11.2; 2025.12.0, 2026.1.0 — fixed in 2025.11.2, 3.5.4
How to fix
Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-69289 or the next vulnerability affects your stack