What’s Vulnerable › Vulnerabilities
CVE-2025-6945: Improper Neutralization of Special Elements used in a Command ('Command Injection') in GitLab
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-15 · updated 2026-10-19
- Weakness: CWE-77
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 17.8 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated attacker to leak sensitive information from confidential issues by injecting hidden prompts into merge request comments.
Affected products
- GitLab: from 17.9.0 before 18.3.6; from 18.4.0 before 18.4.4; from 18.5.0 before 18.5.2 — fixed in 18.3.6, 18.4.4, 18.5.2
How to fix
Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/11/12/patch-release-gitlab-18-5-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/552611
- https://hackerone.com/reports/3173458
Get alerted when CVE-2025-6945 or the next vulnerability affects your stack