What’s Vulnerable › Vulnerabilities
CVE-2025-6948: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 17.11 before 17.11.6, 18.0 before 18.0.4, and 18.1 before 18.1.2 that, under certain conditions, could have allowed a successful attacker to execute actions on behalf of users by injecting malicious content.
Affected products
- GitLab: from 17.11.0 before 17.11.6; from 18.0.0 before 18.0.4; from 18.1.0 before 18.1.2 — fixed in 17.11.6, 18.0.4, 18.1.2
How to fix
Upgrade to a fixed version: GitLab 17.11.6, 18.0.4, 18.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6948 or the next vulnerability affects your stack