What’s Vulnerable › Vulnerabilities

CVE-2025-6965: Integer Truncation on SQLite

Description

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

Affected products

How to fix

Upgrade to a fixed version: Apple iPadOS 26.0.0; Apple Iphone Os 26.0.0; Apple macOS 26.0.0; Apple tvOS 26.0.0; Apple visionOS 26.0.0; Apple watchOS 26.0.0; Siemens RUGGEDCOM CROSSBOW 5.8; Siemens Sidis Prime 4.0.800; SQLite 3.50.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-6965 or the next vulnerability affects your stack