What’s Vulnerable › Vulnerabilities
CVE-2025-69662
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-30 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL injection vulnerability in geopandas before v.1.1.2 allows an attacker to obtain sensitive information via the to_postgis()` function being used to write GeoDataFrames to a PostgreSQL database.
Affected products
- Geopandas: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: Geopandas 1.1.2. Check the vendor advisory for mitigations.
References
- https://aydinnyunus.github.io/2025/12/27/sql-injection-geopandas/
- https://github.com/geopandas/geopandas/pull/3681
- https://lists.debian.org/debian-lts-announce/2026/04/msg00025.html
Get alerted when CVE-2025-69662 or the next vulnerability affects your stack