What’s Vulnerable › Vulnerabilities
CVE-2025-6970: Events Manager <= 7.0.3 - Unauthenticated SQL Injection via `orderby` Parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 56.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-09 · updated 2026-06-17
- Weakness: CWE-89
Description
The Events Manager – Calendar, Bookings, Tickets, and more! plugin for WordPress is vulnerable to time-based SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 7.0.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- netweblogic Events Manager – Calendar, Bookings, Tickets, and more!: before 6.6.5; from 7.0.1 before 7.0.4 — fixed in 6.6.5, 7.0.4
How to fix
Upgrade to a fixed version: netweblogic Events Manager – Calendar, Bookings, Tickets, and more! 6.6.5, 7.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/events-manager/tags/7.0.3/classes/em-object.php#L1060
- https://plugins.trac.wordpress.org/changeset/3321403/events-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7320c06e-a7a7-4ed0-93cd-e85d74bae73f?source=cve
Get alerted when CVE-2025-6970 or the next vulnerability affects your stack