What’s Vulnerable › Vulnerabilities
CVE-2025-6975: Event Manager <= 7.0.3 - Reflected Cross-Site Scripting via `calendar_header` Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Events Manager – Calendar, Bookings, Tickets, and more! plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘calendar_header’ parameter in all versions up to, and including, 7.0.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- netweblogic Events Manager – Calendar, Bookings, Tickets, and more!: before 6.6.5; from 7.0.1 before 7.0.4 — fixed in 6.6.5, 7.0.4
How to fix
Upgrade to a fixed version: netweblogic Events Manager – Calendar, Bookings, Tickets, and more! 6.6.5, 7.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/events-manager/tags/7.0.3/templates/calendar/section-header-navigation.php#L8
- https://plugins.trac.wordpress.org/changeset/3321403/events-manager
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b6e3e59b-837b-4058-b7bc-a22cff22afb4?source=cve
Get alerted when CVE-2025-6975 or the next vulnerability affects your stack