What’s Vulnerable › Vulnerabilities
CVE-2025-6981: Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-15 · updated 2026-06-17
- Weakness: CWE-863
Description
An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3
Affected products
- GitHub Enterprise Server: before 3.14.5; from 3.15.0 before 3.15.10; from 3.16.0 before 3.16.6; from 3.17.0 before 3.17.3 — fixed in 3.14.5, 3.15.10, 3.16.6, 3.17.3
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.14.5, 3.15.10, 3.16.6, 3.17.3. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.15
- https://docs.github.com/en/enterprise-server@3.15/admin/release-notes#3.15.10
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.6
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.3
Get alerted when CVE-2025-6981 or the next vulnerability affects your stack