What’s Vulnerable › Vulnerabilities
CVE-2025-6993: Ultimate WP Mail 1.0.17 - 1.3.6 - Missing Authorization to Authenticated (Contributor+) Privilege Escalation via get_email_log_details Function
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The Ultimate WP Mail plugin for WordPress is vulnerable to Privilege Escalation due to improper authorization within the get_email_log_details() AJAX handler in versions 1.0.17 to 1.3.6. The handler reads the client-supplied post_id and retrieves the corresponding email log post content (including the password-reset link), relying only on the ‘edit_posts’ capability without restricting to administrators or validating ownership. This makes it possible for authenticated attackers, with Contributor-level access and above, to harvest an admin’s reset link and elevate their privileges to administrator.
Affected products
- Rustaurius Ultimate WP Mail: from 1.0.17 before 1.3.7 — fixed in 1.3.7
How to fix
Upgrade to a fixed version: Rustaurius Ultimate WP Mail 1.3.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-wp-mail/tags/1.3.6/includes/Ajax.class.php
- https://plugins.trac.wordpress.org/changeset/3328277
- https://wordpress.org/plugins/ultimate-wp-mail/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b19794de-b623-4017-bd91-73986383c58b?source=cve
Get alerted when CVE-2025-6993 or the next vulnerability affects your stack