What’s Vulnerable › Vulnerabilities
CVE-2025-6997: ThemeREX Addons <= 2.35.1.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via trx_addons_get_svg_from_file Function
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The ThemeREX Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 2.35.1.1 due to insufficient input sanitization and output escaping. The plugin’s SVG rendering routine calls the trx_addons_get_svg_from_file() function on an unvalidated 'svg' parameter supplied via the shortcode or Elementor widget settings, then outputs it via the trx_addons_show_layout() function. Because there is no check on the URL’s origin, scheme, or the SVG content itself, authenticated attackers, with Contributor-level access and above, can supply a remote SVG and inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- ThemeREX Addons: before 2.35.2.2 — fixed in 2.35.2.2
How to fix
Upgrade to a fixed version: ThemeREX Addons 2.35.2.2. Check the vendor advisory for mitigations.
References
- https://themerex.net/wp/download_plugins/themerex-addons/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e1b19017-b2f0-4c3b-b263-1fbec6f1dce4?source=cve
Get alerted when CVE-2025-6997 or the next vulnerability affects your stack