What’s Vulnerable › Vulnerabilities

CVE-2025-7000: Insertion of Sensitive Information Into Sent Data in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.6 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2, that, under specific conditions, could have allowed unauthorized users to view confidential branch names by accessing project issues with related merge requests.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.3.6, 18.4.4, 18.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-7000 or the next vulnerability affects your stack