What’s Vulnerable › Vulnerabilities
CVE-2025-7001: Insufficient Granularity of Access Control in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-24 · updated 2026-06-17
- Weakness: CWE-1220
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 15.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed priviledged users to access certain resource_group information through the API which should have been unavailable.
Affected products
- GitLab: from 15.0.0 before 18.0.5; from 18.1.0 before 18.1.3; 18.2 — fixed in 18.0.5, 18.1.3
How to fix
Upgrade to a fixed version: GitLab 18.0.5, 18.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7001 or the next vulnerability affects your stack