What’s Vulnerable › Vulnerabilities
CVE-2025-7035: Media Library Assistant <= 3.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via mla_tag_cloud and mla_term_list Shortcodes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Media Library Assistant plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's mla_tag_cloud and mla_term_list shortcodes in all versions up to, and including, 3.26 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- dglingren Media Library Assistant: before 3.27 — fixed in 3.27
How to fix
Upgrade to a fixed version: dglingren Media Library Assistant 3.27. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/media-library-assistant/tags/3.26/includes/class-mla-shortcode-tag-cloud.php
- https://plugins.trac.wordpress.org/browser/media-library-assistant/tags/3.26/includes/class-mla-shortcode-term-list.php
- https://plugins.trac.wordpress.org/browser/media-library-assistant/tags/3.26/includes/class-mla-shortcodes.php
- https://plugins.trac.wordpress.org/changeset/3327861
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b6e02a2b-9033-4022-a7d7-1c81a7f02f83?source=cve
Get alerted when CVE-2025-7035 or the next vulnerability affects your stack