What’s Vulnerable › Vulnerabilities
CVE-2025-7044: Privilege Escalation in MAAS via Websocket Request Manipulation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-03 · updated 2026-10-18
- Weakness: CWE-269
Description
An Improper Input Validation vulnerability exists in the user websocket handler of MAAS. An authenticated, unprivileged attacker can intercept a user.update websocket request and inject the is_superuser property set to true. The server improperly validates this input, allowing the attacker to self-promote to an administrator role. This results in full administrative control over the MAAS deployment.
Affected products
- Ubuntu MAAS: from 3.3.0 before 3.3.11; from 3.4.0 before 3.4.9; from 3.5.0 before 3.5.9; from 3.6.0 before 3.6.2 — fixed in 3.3.11, 3.4.9, 3.5.9, 3.6.2
How to fix
Upgrade to a fixed version: Ubuntu MAAS 3.3.11, 3.4.9, 3.5.9, 3.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-7044 or the next vulnerability affects your stack