What’s Vulnerable › Vulnerabilities
CVE-2025-7053: Cockpit save cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.
Affected products
- cockpit-hq/cockpit: through 2.11.3
References
- https://github.com/Cockpit-HQ/Cockpit/commit/bdcd5e3bc651c0839c7eea807f3eb6af856dbc76
- https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.11.4
- https://vuldb.com/?ctiid.314819
- https://vuldb.com/?id.314819
- https://vuldb.com/?submit.605594
- https://vuldb.com/?submit.605594
Get alerted when CVE-2025-7053 or the next vulnerability affects your stack