What’s Vulnerable › Vulnerabilities
CVE-2025-7057: Stored XSS in Quiz
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - Quiz Extension allows Stored XSS.This issue affects Mediawiki - Quiz Extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.
Affected products
- Wikimedia Foundation Mediawiki - Quiz Extension: from 1.39.x before 1.39.13; from 1.42.x before 1.42.7; from 1.43.x before 1.43.2 — fixed in 1.39.13, 1.42.7, 1.43.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - Quiz Extension 1.39.13, 1.42.7, 1.43.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Quiz/+/1166274
- https://phabricator.wikimedia.org/T394612
Get alerted when CVE-2025-7057 or the next vulnerability affects your stack