What’s Vulnerable › Vulnerabilities
CVE-2025-7062: Stored Cross-Site Scripting via file upload in H5P module (h5p-nodejs-library) of Lumi Education
- Severity: medium (CVSS 5.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-19
- Weakness: CWE-20
Description
A stored cross-site scripting (XSS) vulnerability has been identified in the H5P module `h5p-nodejs-library` by Lumi Education UG in versions up to and including 10.0.4. The library allows users to upload H5P content that contains malicious JavaScript. This code is then executed in the browsers of other users who view the affected H5P content.
Affected products
- Lumi Education UG h5p-nodejs-library: before 10.0.4 — fixed in 10.0.4
How to fix
Upgrade to a fixed version: Lumi Education UG h5p-nodejs-library 10.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/Lumieducation/H5P-Nodejs-library/releases/tag/v10.0.4
- https://www.schutzwerk.com/en/blog/schutzwerk-sa-2024-007/
- http://seclists.org/fulldisclosure/2026/Sep/41
Get alerted when CVE-2025-7062 or the next vulnerability affects your stack