What’s Vulnerable › Vulnerabilities
CVE-2025-70887
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-269
Description
An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
Affected products
- Ralphje Signify: before 0.9.2 — fixed in 0.9.2
How to fix
Upgrade to a fixed version: Ralphje Signify 0.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/mtrojnar/osslsigncode/issues/475
- https://github.com/mtrojnar/osslsigncode/pull/477
- https://github.com/mtrojnar/osslsigncode/releases/tag/2.11
- https://github.com/ralphje/signify/commit/64f21c0cc06cea0536370686ca3ba7a01e4adaa8
- https://github.com/ralphje/signify/issues/60
Get alerted when CVE-2025-70887 or the next vulnerability affects your stack