What’s Vulnerable › Vulnerabilities
CVE-2025-7106: Authorization Bypass due to Incorrect Access Control in danny-avila/librechat
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-23 · updated 2026-10-11
- Weakness: CWE-284
Description
danny-avila/librechat is affected by an authorization bypass vulnerability due to improper access control checks. The `checkAccess` function in `api/server/middleware/roles/access.js` uses `permissions.some()` to validate permissions, which incorrectly grants access if only one of multiple required permissions is present. This allows users with the 'USER' role to create agents despite having `CREATE: false` permission, as the check for `['USE', 'CREATE']` passes with just `USE: true`. This vulnerability affects other permission checks as well, such as `PROMPTS`. The issue is present in all versions prior to the fix.
Affected products
- danny-avila LibreChat: before 0.7.9 — fixed in 0.7.9
How to fix
Upgrade to a fixed version: danny-avila LibreChat 0.7.9. Check the vendor advisory for mitigations.
References
- https://github.com/danny-avila/librechat/commit/91a2df47599c09d80886bfc28e0ccf1debd42110
- https://huntr.com/bounties/7de2765b-d1fe-4495-9144-220070857c48
Get alerted when CVE-2025-7106 or the next vulnerability affects your stack