What’s Vulnerable › Vulnerabilities
CVE-2025-71084: RDMA/cm: Fix leaking the multicast GID table reference
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-10-19
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/cm: Fix leaking the multicast GID table reference If the CM ID is destroyed while the CM event for multicast creating is still queued the cancel_work_sync() will prevent the work from running which also prevents destroying the ah_attr. This leaks a refcount and triggers a WARN: GID entry ref leak for dev syz1 index 2 ref=573 WARNING: CPU: 1 PID: 655 at drivers/infiniband/core/cache.c:809 release_gid_table drivers/infiniband/core/cache.c:806 [inline] WARNING: CPU: 1 PID: 655 at drivers/infiniband/core/cache.c:809 gid_table_release_one+0x284/0x3cc drivers/infiniband/core/cache.c:886 Destroy the ah_attr after canceling the work, it is safe to call this twice.
Affected products
- Linux kernel: from 5.10.20 before 5.10.248; from 5.11.3 before 5.12; from 5.12.1 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64 — fixed in 5.10.248, 5.12, 5.15.198, 6.1.160, 6.12.64, 6.18.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.12, 5.15.198, 6.1.160. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3ba6d01c4b3c584264dc733c6a2ecc5bbc8e0bb5
- https://git.kernel.org/stable/c/57f3cb6c84159d12ba343574df2115fb18dd83ca
- https://git.kernel.org/stable/c/5cb34bb5fd726491b809efbeb5cfd63ae5bf9cf3
- https://git.kernel.org/stable/c/ab668a58c4a2ccb6d54add7a76f2f955d15d0196
- https://git.kernel.org/stable/c/abf38398724ecc888f62c678d288da40d11878af
- https://git.kernel.org/stable/c/c0acdee513239e1d6e1b490f56be0e6837dfd162
- https://git.kernel.org/stable/c/d5ce588a9552878859a4d44b70b724216c188a5f
Get alerted when CVE-2025-71084 or the next vulnerability affects your stack