What’s Vulnerable › Vulnerabilities
CVE-2025-71086: net: rose: fix invalid array index in rose_kill_by_device()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-10-15
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: net: rose: fix invalid array index in rose_kill_by_device() rose_kill_by_device() collects sockets into a local array[] and then iterates over them to disconnect sockets bound to a device being brought down. The loop mistakenly indexes array[cnt] instead of array[i]. For cnt < ARRAY_SIZE(array), this reads an uninitialized entry; for cnt == ARRAY_SIZE(array), it is an out-of-bounds read. Either case can lead to an invalid socket pointer dereference and also leaks references taken via sock_hold(). Fix the index to use i.
Affected products
- Linux kernel: from 4.19.304 before 4.20; from 5.4.266 before 5.5; from 5.10.206 before 5.10.248; from 5.15.146 before 5.15.198; from 6.1.70 before 6.1.160; from 6.6.9 before 6.6.120 — fixed in 4.20, 5.10.248, 5.15.198, 5.5, 6.1.160, 6.12.64
How to fix
Upgrade to a fixed version: Linux kernel 4.20, 5.10.248, 5.15.198, 5.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1418c12cd3bba79dc56b57b61c99efe40f579981
- https://git.kernel.org/stable/c/6595beb40fb0ec47223d3f6058ee40354694c8e4
- https://git.kernel.org/stable/c/819fb41ae54960f66025802400c9d3935eef4042
- https://git.kernel.org/stable/c/92d900aac3a5721fb54f3328f1e089b44a861c38
- https://git.kernel.org/stable/c/9f6185a32496834d6980b168cffcccc2d6b17280
- https://git.kernel.org/stable/c/b409ba9e1e63ccf3ab4cc061e33c1f804183543e
- https://git.kernel.org/stable/c/ed2639414d43ba037f798eaf619e878309310451
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-71086 or the next vulnerability affects your stack