What’s Vulnerable › Vulnerabilities
CVE-2025-71108: usb: typec: ucsi: Handle incorrect num_connectors capability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-10-19
- Weakness: CWE-20
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: ucsi: Handle incorrect num_connectors capability The UCSI spec states that the num_connectors field is 7 bits, and the 8th bit is reserved and should be set to zero. Some buggy FW has been known to set this bit, and it can lead to a system not booting. Flag that the FW is not behaving correctly, and auto-fix the value so that the system boots correctly. Found on Lenovo P1 G8 during Linux enablement program. The FW will be fixed, but seemed worth addressing in case it hit platforms that aren't officially Linux supported.
Affected products
- Linux kernel: from 4.13.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.3 — fixed in 5.10.248, 5.15.198, 6.1.160, 6.12.64, 6.18.3, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.160, 6.12.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/07c8d2a109d847775b3b4e2c3294c8e1eea75432
- https://git.kernel.org/stable/c/132fe187e0d940f388f839fe2cde9b84106ad20d
- https://git.kernel.org/stable/c/3042a57a8e8bce4a3100c3f6f03dc372aab24943
- https://git.kernel.org/stable/c/30cd2cb1abf4c4acdb1ddb468c946f68939819fb
- https://git.kernel.org/stable/c/58941bbb0050e365a98c64f1fc4a9a0ac127dba6
- https://git.kernel.org/stable/c/914605b0de8128434eafc9582445306830748b93
- https://git.kernel.org/stable/c/f72f97d0aee4a993a35f2496bca5efd24827235d
Get alerted when CVE-2025-71108 or the next vulnerability affects your stack