What’s Vulnerable › Vulnerabilities
CVE-2025-71109: MIPS: ftrace: Fix memory corruption when kernel is located beyond 32 bits
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-10-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: MIPS: ftrace: Fix memory corruption when kernel is located beyond 32 bits Since commit e424054000878 ("MIPS: Tracing: Reduce the overhead of dynamic Function Tracer"), the macro UASM_i_LA_mostly has been used, and this macro can generate more than 2 instructions. At the same time, the code in ftrace assumes that no more than 2 instructions can be generated, which is why it stores them in an int[2] array. However, as previously noted, the macro UASM_i_LA_mostly (and now UASM_i_LA) causes a buffer overflow when _mcount is beyond 32 bits. This leads to corruption of the variables located in the __read_mostly section. This corruption was observed because the variable __cpu_primary_thread_mask was corrupted, causing a hang very early during boot. This fix prevents the corruption by avoiding the generation of instructions if they could exceed 2 instructions in length. Fortunately, insn_la_mcount is only used if the instrumented code is located outside the kernel code section, so dynamic ftrace can still be used, albeit in a more limited scope. This is still preferable to corrupting memory and/or crashing the kernel.
Affected products
- Linux kernel: from 2.6.35.1 before 6.12.64; from 6.13 before 6.18.3; 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5, 6.19-rc6 (+2); 2.6.35 — fixed in 6.12.64, 6.18.3
- Linux: 2.6.35 — fixed in 6.19
How to fix
Upgrade to a fixed version: Linux kernel 6.12.64, 6.18.3; Linux 6.19. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/36dac9a3dda1f2bae343191bc16b910c603cac25
- https://git.kernel.org/stable/c/3f7a003fe2646337fbc5dd41051ad6754ac34064
- https://git.kernel.org/stable/c/7f39b9d0e86ed6236b9a5fb67616ab1f76c4f150
- https://git.kernel.org/stable/c/9cfda98cf02eacfa6b09076e98bd479fd73407c2
- https://git.kernel.org/stable/c/e3e33ac2eb69d595079a1a1e444c2fb98efdd42d
Get alerted when CVE-2025-71109 or the next vulnerability affects your stack