What’s Vulnerable › Vulnerabilities
CVE-2025-71112: net: hns3: add VLAN id validation before using
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: net: hns3: add VLAN id validation before using Currently, the VLAN id may be used without validation when receive a VLAN configuration mailbox from VF. The length of vlan_del_fail_bmap is BITS_TO_LONGS(VLAN_N_VID). It may cause out-of-bounds memory access once the VLAN id is bigger than or equal to VLAN_N_VID. Therefore, VLAN id needs to be checked to ensure it is within the range of VLAN_N_VID.
Affected products
- Linux kernel: from 5.3.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.3 — fixed in 5.10.248, 5.15.198, 6.1.160, 6.12.64, 6.18.3, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.160, 6.12.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/00e56a7706e10b3d00a258d81fcb85a7e96372d6
- https://git.kernel.org/stable/c/42c91dfa772c57de141e5a55a187ac760c0fd7e1
- https://git.kernel.org/stable/c/46c7d9fe8dd869ea5de666aba8c1ec1061ca44a8
- https://git.kernel.org/stable/c/6ef935e65902bfed53980ad2754b06a284ea8ac1
- https://git.kernel.org/stable/c/91a51d01be5c9f82c12c2921ca5cceaa31b67128
- https://git.kernel.org/stable/c/95cca255a7a5ad782639ff0298c2a486707d1046
- https://git.kernel.org/stable/c/b7b4f3bf118f51b67691a55b464f04452e5dc6fc
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-71112 or the next vulnerability affects your stack