What’s Vulnerable › Vulnerabilities
CVE-2025-71116: libceph: make decode_pool() more resilient against corrupted osdmaps
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: libceph: make decode_pool() more resilient against corrupted osdmaps If the osdmap is (maliciously) corrupted such that the encoded length of ceph_pg_pool envelope is less than what is expected for a particular encoding version, out-of-bounds reads may ensue because the only bounds check that is there is based on that length value. This patch adds explicit bounds checks for each field that is decoded or skipped.
Affected products
- Linux kernel: from 3.9.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.3 — fixed in 5.10.248, 5.15.198, 6.1.160, 6.12.64, 6.18.3, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.160, 6.12.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/145d140abda80e33331c5781d6603014fa75d258
- https://git.kernel.org/stable/c/2acb8517429ab42146c6c0ac1daed1f03d2fd125
- https://git.kernel.org/stable/c/5d0d8c292531fe356c4e94dcfdf7d7212aca9957
- https://git.kernel.org/stable/c/8c738512714e8c0aa18f8a10c072d5b01c83db39
- https://git.kernel.org/stable/c/c82e39ff67353a5a6cbc07b786b8690bd2c45aaa
- https://git.kernel.org/stable/c/d061be4c8040ffb1110d537654a038b8b6ad39d2
- https://git.kernel.org/stable/c/e927ab132b87ba3f076705fc2684d94b24201ed1
Get alerted when CVE-2025-71116 or the next vulnerability affects your stack