What’s Vulnerable › Vulnerabilities
CVE-2025-71131: crypto: seqiv - Do not use req->iv after crypto_aead_encrypt
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: seqiv - Do not use req->iv after crypto_aead_encrypt As soon as crypto_aead_encrypt is called, the underlying request may be freed by an asynchronous completion. Thus dereferencing req->iv after it returns is invalid. Instead of checking req->iv against info, create a new variable unaligned_info and use it for that purpose instead.
Affected products
- Linux kernel: from 2.6.25.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.4 — fixed in 5.10.248, 5.15.198, 6.1.160, 6.12.64, 6.18.4, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.160, 6.12.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0279978adec6f1296af66b642cce641c6580be46
- https://git.kernel.org/stable/c/18202537856e0fae079fed2c9308780bcff2bb9d
- https://git.kernel.org/stable/c/50f196d2bbaee4ab2494bb1b0d294deba292951a
- https://git.kernel.org/stable/c/50fdb78b7c0bcc550910ef69c0984e751cac72fa
- https://git.kernel.org/stable/c/5476f7f8a311236604b78fcc5b2a63b3a61b0169
- https://git.kernel.org/stable/c/baf0e2d1e03ddb04781dfe7f22a654d3611f69b2
- https://git.kernel.org/stable/c/ccbb96434d88e32358894c879457b33f7508e798
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-71131 or the next vulnerability affects your stack