What’s Vulnerable › Vulnerabilities
CVE-2025-71136: media: adv7842: Avoid possible out-of-bounds array accesses in adv7842_cp_log_status()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-07-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: media: adv7842: Avoid possible out-of-bounds array accesses in adv7842_cp_log_status() It's possible for cp_read() and hdmi_read() to return -EIO. Those values are further used as indexes for accessing arrays. Fix that by checking return values where it's needed. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 3.12.1 before 5.10.248; from 5.11 before 5.15.198; from 5.16 before 6.1.160; from 6.2 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.4 — fixed in 5.10.248, 5.15.198, 6.1.160, 6.12.64, 6.18.4, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 5.10.248, 5.15.198, 6.1.160, 6.12.64. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/60dde0960e3ead8a9569f6c494d90d0232ac0983
- https://git.kernel.org/stable/c/8163419e3e05d71dcfa8fb49c8fdf8d76908fe51
- https://git.kernel.org/stable/c/a73881ae085db5702d8b13e2fc9f78d51c723d3f
- https://git.kernel.org/stable/c/b693d48a6ed0cd09171103ad418e4a693203d6e4
- https://git.kernel.org/stable/c/d6a22a4a96e4dfe6897cb3532d2b3016d87706f0
- https://git.kernel.org/stable/c/f81ee181cb036d046340c213091b69d9a8701a76
- https://git.kernel.org/stable/c/f913b9a2ccd6114b206b9e91dae5e3dc13a415a0
Get alerted when CVE-2025-71136 or the next vulnerability affects your stack