What’s Vulnerable › Vulnerabilities
CVE-2025-71143: clk: samsung: exynos-clkout: Assign .num before accessing .hws
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-14 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: clk: samsung: exynos-clkout: Assign .num before accessing .hws Commit f316cdff8d67 ("clk: Annotate struct clk_hw_onecell_data with __counted_by") annotated the hws member of 'struct clk_hw_onecell_data' with __counted_by, which informs the bounds sanitizer (UBSAN_BOUNDS) about the number of elements in .hws[], so that it can warn when .hws[] is accessed out of bounds. As noted in that change, the __counted_by member must be initialized with the number of elements before the first array access happens, otherwise there will be a warning from each access prior to the initialization because the number of elements is zero. This occurs in exynos_clkout_probe() due to .num being assigned after .hws[] has been accessed: UBSAN: array-index-out-of-bounds in drivers/clk/samsung/clk-exynos-clkout.c:178:18 index 0 is out of range for type 'clk_hw *[*]' Move the .num initialization to before the first access of .hws[], clearing up the warning.
Affected products
- Linux kernel: from 6.6.1 before 6.6.120; from 6.7 before 6.12.64; from 6.13 before 6.18.4; 6.6, 6.19-rc1, 6.19-rc2, 6.19-rc3, 6.19-rc4, 6.19-rc5 (+3) — fixed in 6.12.64, 6.18.4, 6.6.120
How to fix
Upgrade to a fixed version: Linux kernel 6.12.64, 6.18.4, 6.6.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/a317f63255ebc3dac378c79c5bff4f8d0561c290
- https://git.kernel.org/stable/c/cf33f0b7df13685234ccea7be7bfe316b60db4db
- https://git.kernel.org/stable/c/eb1f3a6ab3efee2b52361879cdc2dc6b11f499c0
- https://git.kernel.org/stable/c/fbf57f5e453dadadb3d29b2d1dbe067e3dc4e236
Get alerted when CVE-2025-71143 or the next vulnerability affects your stack