What’s Vulnerable › Vulnerabilities
CVE-2025-71155: KVM: s390: Fix gmap_helper_zap_one_page() again
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-07-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: s390: Fix gmap_helper_zap_one_page() again A few checks were missing in gmap_helper_zap_one_page(), which can lead to memory corruption in the guest under specific circumstances. Add the missing checks.
Affected products
- Linux kernel: from 6.17.4 before 6.18; from 6.18 before 6.18.4 — fixed in 6.18, 6.18.4
How to fix
Upgrade to a fixed version: Linux kernel 6.18, 6.18.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2af2abbcbf8573100288e8f8aea2dab8a2a0ceb7
- https://git.kernel.org/stable/c/2f393c228cc519ddf19b8c6c05bf15723241aa96
Get alerted when CVE-2025-71155 or the next vulnerability affects your stack