What’s Vulnerable › Vulnerabilities
CVE-2025-71158: gpio: mpsse: ensure worker is torn down
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: mpsse: ensure worker is torn down When an IRQ worker is running, unplugging the device would cause a crash. The sealevel hardware this driver was written for was not hotpluggable, so I never realized it. This change uses a spinlock to protect a list of workers, which it tears down on disconnect.
Affected products
- Linux kernel: from 6.13 before 6.18.6 — fixed in 6.18.6
How to fix
Upgrade to a fixed version: Linux kernel 6.18.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/179ef1127d7a4f09f0e741fa9f30b8a8e7886271
- https://git.kernel.org/stable/c/472d900c8bcac301ae0e40fdca7db799bd989ff5
Get alerted when CVE-2025-71158 or the next vulnerability affects your stack