What’s Vulnerable › Vulnerabilities
CVE-2025-71220: smb/server: call ksmbd_session_rpc_close() on error path in create_smb2_pipe()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-14 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: smb/server: call ksmbd_session_rpc_close() on error path in create_smb2_pipe() When ksmbd_iov_pin_rsp() fails, we should call ksmbd_session_rpc_close().
Affected products
- Linux kernel: from 5.15.145 before 5.15.200; from 6.1.71 before 6.1.163; from 6.6 before 6.6.124; from 6.7 before 6.12.70; from 6.13 before 6.18.10; 6.19-rc1, 6.19-rc2, 6.19-rc3 — fixed in 5.15.200, 6.1.163, 6.12.70, 6.18.10, 6.6.124
How to fix
Upgrade to a fixed version: Linux kernel 5.15.200, 6.1.163, 6.12.70, 6.18.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/04dd114b682a4ccaeba2c2bad049c8b50ce740d8
- https://git.kernel.org/stable/c/2b7b4df87fe6f2db6ee45f475de6b37b8b8e5d29
- https://git.kernel.org/stable/c/7c28f8eef5ac5312794d8a52918076dcd787e53b
- https://git.kernel.org/stable/c/a2c68e256fb7a4ac34154c6e865a1389acca839f
- https://git.kernel.org/stable/c/ac18761b530b5dd40f59af8a25902282e5512854
- https://git.kernel.org/stable/c/fdda836fcee6fdbcccc24e3679097efb583f581f
Get alerted when CVE-2025-71220 or the next vulnerability affects your stack