What’s Vulnerable › Vulnerabilities
CVE-2025-71240: SPIP < 4.2.15 Cross-Site Scripting via Code Tags
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
SPIP before 4.2.15 allows Cross-Site Scripting (XSS) via crafted content in HTML code tags. The application does not properly verify JavaScript within code tags, allowing an attacker to inject malicious scripts that execute in a victim's browser.
Affected products
- SPIP: from 4.2.0 before 4.2.15 — fixed in 4.2.15
How to fix
Upgrade to a fixed version: SPIP 4.2.15. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-de-maintenance-et-securite-sortie-de-SPIP-4-2-15.html
- https://git.spip.net/spip/spip
- https://www.vulncheck.com/advisories/spip-cross-site-scripting-via-code-tags
Get alerted when CVE-2025-71240 or the next vulnerability affects your stack