What’s Vulnerable › Vulnerabilities

CVE-2025-71241: SPIP < 4.3.6 Cross-Site Scripting in Private Area

Description

SPIP before 4.3.6, 4.2.17, and 4.1.20 allows Cross-Site Scripting (XSS) in the private area. The content of the error message displayed by the 'transmettre' API is not properly sanitized, allowing an attacker to inject malicious scripts. This vulnerability is mitigated by the SPIP security screen.

Affected products

How to fix

Upgrade to a fixed version: SPIP 4.1.20, 4.2.17, 4.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-71241 or the next vulnerability affects your stack