What’s Vulnerable › Vulnerabilities
CVE-2025-71265: fs: ntfs3: fix infinite loop in attr_load_runs_range on inconsistent metadata
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-10-15
- Weakness: CWE-835
Description
In the Linux kernel, the following vulnerability has been resolved: fs: ntfs3: fix infinite loop in attr_load_runs_range on inconsistent metadata We found an infinite loop bug in the ntfs3 file system that can lead to a Denial-of-Service (DoS) condition. A malformed NTFS image can cause an infinite loop when an attribute header indicates an empty run list, while directory entries reference it as containing actual data. In NTFS, setting evcn=-1 with svcn=0 is a valid way to represent an empty run list, and run_unpack() correctly handles this by checking if evcn + 1 equals svcn and returning early without parsing any run data. However, this creates a problem when there is metadata inconsistency, where the attribute header claims to be empty (evcn=-1) but the caller expects to read actual data. When run_unpack() immediately returns success upon seeing this condition, it leaves the runs_tree uninitialized with run->runs as a NULL. The calling function attr_load_runs_range() assumes that a successful return means that the runs were loaded and sets clen to 0, expecting the next run_lookup_entry() call to succeed. Because runs_tree remains uninitialized, run_lookup_entry() continues to fail, and the loop increments vcn by zero (vcn += 0), leading to an infinite loop. This patch adds a retry counter to detect when run_lookup_entry() fails consecutively after attr_load_runs_vcn(). If the run is still not found on the second attempt, it indicates corrupted metadata and returns -EINVAL, preventing the Denial-of-Service (DoS) vulnerability.
Affected products
- Linux kernel: from 5.15 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 5.15.202, 6.1.165, 6.12.75, 6.18.16, 6.19.6, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 5.15.202, 6.1.165, 6.12.75, 6.18.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3c3a6e951b9b53dab2ac460a655313cf04c4a10a
- https://git.kernel.org/stable/c/4b90f16e4bb5607fb35e7802eb67874038da4640
- https://git.kernel.org/stable/c/6f07a590616ff5f57f7c041d98e463fad9e9f763
- https://git.kernel.org/stable/c/78b61f7eac37a63284774b147f38dd0be6cad43c
- https://git.kernel.org/stable/c/a89bc96d5abd8a4a8d5d911884ea347efcdf460b
- https://git.kernel.org/stable/c/af839013c70a24779f9d1afb1575952009312d38
- https://git.kernel.org/stable/c/c0b43c45d45f59e7faad48675a50231a210c379b
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-71265 or the next vulnerability affects your stack