What’s Vulnerable › Vulnerabilities
CVE-2025-71273: wifi: rtw88: Use devm_kmemdup() in rtw_set_supported_band()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-10-30
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: rtw88: Use devm_kmemdup() in rtw_set_supported_band() Simplify the code by using device managed memory allocations. This also fixes a memory leak in rtw_register_hw(). The supported bands were not freed in the error path. Copied from commit 145df52a8671 ("wifi: rtw89: Convert rtw89_core_set_supported_band to use devm_*").
Affected products
- Linux kernel: from 5.2 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 6.12.75, 6.18.16, 6.19.6
- Linux: 5.2 — fixed in 7.0
How to fix
Upgrade to a fixed version: Linux kernel 6.12.75, 6.18.16, 6.19.6; Linux 7.0. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1bd90e0a99fdc8dc5deb3c92bf865e4496b4b311
- https://git.kernel.org/stable/c/2ba12401cc1f2d970fa2e7d5b15abde3f5abd40d
- https://git.kernel.org/stable/c/537723ada6d6655f0a2f48ab000fd9b0358bb442
- https://git.kernel.org/stable/c/9b5418070ee8468fac9e8bf641c83d46b85bff30
- https://git.kernel.org/stable/c/ad9b80ee310ed734482a2e5da874b67f88ac0ef8
- https://git.kernel.org/stable/c/d57e31c8df7b8bb684c6b56854676972a8b7c8ed
Get alerted when CVE-2025-71273 or the next vulnerability affects your stack