What’s Vulnerable › Vulnerabilities
CVE-2025-71278: XenForo OAuth2 Unauthorized Scope Request
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-01 · updated 2026-06-17
- Weakness: CWE-863
Description
XenForo before 2.3.5 allows OAuth2 client applications to request unauthorized scopes. This affects any customer using OAuth2 clients on any version of XenForo 2.3 prior to 2.3.5, potentially allowing client applications to gain access beyond their intended authorization level.
Affected products
- XenForo: from 2.3.0 before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: XenForo 2.3.5. Check the vendor advisory for mitigations.
References
- https://www.vulncheck.com/advisories/xenforo-oauth2-unauthorized-scope-request
- https://xenforo.com/community/threads/xenforo-2-3-5-includes-security-fix-add-ons-released.228812/
Get alerted when CVE-2025-71278 or the next vulnerability affects your stack