What’s Vulnerable › Vulnerabilities
CVE-2025-71331: Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-20 · updated 2026-10-19
- Weakness: CWE-80
Description
Flowise before 3.0.8 contains a cross-site scripting (XSS) vulnerability caused by insufficient input filtering in chat messages and custom agent functions. An attacker can inject malicious JavaScript by sending an iframe payload (e.g., <iframe src="javascript:alert(document.cookie)">) in a chat box, or by having a custom agent function return an XSS payload from an external website. The injected script executes in the victim's browser, enabling theft of cookies and session data.
Affected products
- FlowiseAI Flowise: before 3.0.8 — fixed in 3.0.8
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wv
- https://www.vulncheck.com/advisories/flowise-cross-site-scripting-in-chat-messages-and-agent-workflows
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wv
Get alerted when CVE-2025-71331 or the next vulnerability affects your stack