What’s Vulnerable › Vulnerabilities
CVE-2025-71335: Flowise - Session Invalidation Failure After Password Change
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-25 · updated 2026-10-12
- Weakness: CWE-613
Description
Flowise before 3.0.10 (affected versions 3.0.7 and earlier) fails to invalidate existing sessions and session tokens after a user changes their password. An attacker who already holds an active session, for example via a stolen session token or a device left logged in, remains authenticated as the legitimate user even after the user rotates their credentials, undermining the security purpose of the password change.
Affected products
- FlowiseAI Flowise: before 3.0.10 — fixed in 3.0.10
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x7rp-qj2h-ghgw
- https://www.vulncheck.com/advisories/flowise-session-invalidation-failure-after-password-change
Get alerted when CVE-2025-71335 or the next vulnerability affects your stack