What’s Vulnerable › Vulnerabilities
CVE-2025-71370: picklescan - Remote Code Execution via torch.jit.unsupported_tensor_ops.execWrapper
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-12
- Weakness: CWE-502
Description
picklescan before 0.0.28 fails to detect malicious torch.jit.unsupported_tensor_ops.execWrapper function calls embedded in pickle files. Attackers can craft malicious pickle files that bypass picklescan detection and execute arbitrary code when loaded via pickle.load().
Affected products
- picklescan: before 0.0.28 — fixed in 0.0.28
How to fix
Upgrade to a fixed version: picklescan 0.0.28. Check the vendor advisory for mitigations.
References
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-vr7h-p6mm-wpmh
- https://www.vulncheck.com/advisories/picklescan-remote-code-execution-via-torch-jit-unsupported-tensor-ops-execwrapper
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-vr7h-p6mm-wpmh
Get alerted when CVE-2025-71370 or the next vulnerability affects your stack