What’s Vulnerable › Vulnerabilities
CVE-2025-71379: vllm - Regular Expression Denial of Service in Multiple Components
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-20 · updated 2026-10-12
- Weakness: CWE-1333
Description
vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.
Affected products
- vllm-project vllm: from 0.6.3 before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-j828-28rj-hfhp
- https://www.vulncheck.com/advisories/vllm-regular-expression-denial-of-service-in-multiple-components
Get alerted when CVE-2025-71379 or the next vulnerability affects your stack