What’s Vulnerable › Vulnerabilities
CVE-2025-71389: Cal.com before 5.9.9 Remote Code Execution via RSC
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-09-29
- Weakness: CWE-94
Description
Cal.com (calcom/cal.diy) before 5.9.9 is vulnerable to unauthenticated remote code execution because it bundles a version of Next.js whose React Server Components (RSC) request handling deserializes attacker-controlled input. A remote attacker can send a crafted RSC request to the server and cause arbitrary code to be executed during server-side processing, without authentication or user interaction. The flaw derives from the upstream Next.js vulnerability CVE-2025-55182 and is resolved in 5.9.9 by updating the affected dependency.
Affected products
- calcom cal.diy: before 5.9.9 — fixed in 5.9.9
How to fix
Upgrade to a fixed version: calcom cal.diy 5.9.9. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-9qr9-h5gf-34mp
- https://github.com/calcom/cal.diy/pull/25592
- https://github.com/calcom/cal.diy/security/advisories/GHSA-qjx2-5xqp-cpf4
- https://www.vulncheck.com/advisories/cal-com-before-remote-code-execution-via-rsc
Get alerted when CVE-2025-71389 or the next vulnerability affects your stack