What’s Vulnerable › Vulnerabilities
CVE-2025-71391: SurrealDB before 2.2.2 Denial of Service via /sql endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-29
- Weakness: CWE-248
Description
SurrealDB versions before 2.2.2 contain an uncaught exception vulnerability in the net module that allows authenticated users to crash the database. Attackers can send crafted HTTP queries containing null bytes to the /sql endpoint, causing an unhandled exception that crashes the SurrealDB instance and any dependent applications.
Affected products
How to fix
Upgrade to a fixed version: surrealdb 2.2.2; surrealdb 2.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-rq86-9m6r-cm3g
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-sql-endpoint
Get alerted when CVE-2025-71391 or the next vulnerability affects your stack